### Revision record

<table>
<thead>
<tr>
<th>Version</th>
<th>Date</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.0</td>
<td>June 2006</td>
<td>Original issue of this document.</td>
</tr>
<tr>
<td>1.2</td>
<td>April 2007</td>
<td>Minor revision. Description of Remote Backup has been removed from this manual.</td>
</tr>
<tr>
<td>1.3</td>
<td>March 2008</td>
<td>Documentation for VDR Explorer 1.31. (Vista support and improved ModBus support).</td>
</tr>
<tr>
<td>1.5</td>
<td>October 2008</td>
<td>References to Voyager Master III included Documentation for VDR explorer 1.4 (Improved tool for data export)</td>
</tr>
<tr>
<td>1.6</td>
<td>September 2010</td>
<td>Description of IMO (IEC61996-1/2) mode for data export tool. Description of Azimuth Thruster object included.</td>
</tr>
</tbody>
</table>
Contents

REVISION RECORD ...........................................................................................................2

1 SCOPE AND PURPOSE ..........................................................................................7
  1.1 References ........................................................................................................7
  1.2 Terms and Abbreviations ................................................................................7

2 SYSTEM OVERVIEW ...........................................................................................8
  2.1 Connecting the PC to a capsule ......................................................................9
  2.2 Connecting the PC to a VDR data disc (Voyage Master II) .........................9

3 GUI DESCRIPTION ..............................................................................................10
  3.1 After startup ..................................................................................................10
    3.1.1 Tool bar .................................................................................................11
    3.1.2 VDR Explorer status bar ......................................................................12
    3.1.3 VDR Explorer play control area .........................................................12

4 REPLAY OF DATA, SHORT GUIDE ................................................................13
  4.1.1 Play control .............................................................................................14
  4.1.2 Tracks .......................................................................................................14

5 CONFIGURATION ................................................................................................15
  5.1 Creating a new configuration .......................................................................15
  5.2 Adding new tab pages ..................................................................................15
    5.2.1 Tab page organizer ...............................................................................16
  5.3 Creating and moving graphical objects .........................................................17
    5.3.1 Creating and moving panels .................................................................17
  5.4 Configuration of graphical objects ................................................................17
    5.4.1 Copy/past of graphical object configuration .......................................18
  5.5 Configuration of Gauges ..............................................................................19
    5.5.1 Dial meter .............................................................................................19
    5.5.2 Vertical bar ............................................................................................21
    5.5.3 Horizontal bar .......................................................................................22
    5.5.4 Compass dial .........................................................................................23
    5.5.5 Horizontal ruler ....................................................................................24
    5.5.6 Doppler log ............................................................................................25
    5.5.7 Rudder indicator ....................................................................................26
    5.5.8 Graph ....................................................................................................27
    5.5.9 Roll and pitch indicator ........................................................................28
    5.5.10 Azimuth Thruster ...............................................................................29
  5.6 Numeric data display ......................................................................................31
    5.6.1 General ..................................................................................................31
    5.6.2 Colors ....................................................................................................31
    5.6.3 Concatenation .........................................................................................31
  5.7 Paper strip .......................................................................................................32
12.1 Configuration of data log ................................................................. 54
  12.1.1 Direct creations of columns ....................................................... 54
  12.1.2 Indirect creations of columns .................................................. 56
  12.1.3 Organizing columns ................................................................. 57
  12.1.4 Maximum number of columns ............................................... 57
12.2 Saving log data to a file ............................................................... 58
  12.2.1 Max file size ........................................................................... 58
  12.2.2 Sample interval ..................................................................... 58
12.3 Preferences .................................................................................. 58
  12.3.1 Directory path for log files ..................................................... 58
  12.3.2 Disable data logging at connect .............................................. 58
13 ALARM PANEL .................................................................................. 59
  13.1.1 Easy localization of alarms source ......................................... 60
13.2 Default setting for alarm panel .................................................... 60
13.3 Configuration of objects for alarms .............................................. 61
14 RELAY OF SERIAL OUTPUT TO OTHER APPLICATIONS ............... 62
  14.1 Output port settings .................................................................... 62
  14.2 Configuration of serial output .................................................... 63
    14.2.1 Merging of data ................................................................. 63
  14.3 Enable/Disable output ............................................................... 63
  14.4 Overflow on serial port ............................................................. 64
  14.5 Serial output and step ............................................................... 64
15 AIS DATA DISPLAY ........................................................................... 65
  15.1 AIS display tab .......................................................................... 65
  15.2 Selecting data source ................................................................. 66
  15.3 Using a AIS display tab ............................................................. 67
  15.4 Symbols for Targets .................................................................. 67
  15.5 Supported messages ................................................................. 68
16 SPECIAL FEATURES .......................................................................... 69
  16.1 Floating windows ....................................................................... 69
    16.1.1 “Windows” drop down menu ............................................. 69
  16.2 Support for PC’s with lower screen resolution ............................ 69
  16.3 Vessel information .................................................................... 69
  16.4 Play control ............................................................................... 69
  16.5 Full screen radar image ............................................................. 69
  16.6 Full screen graph object ............................................................ 69
17 NMEA SENTENCE FORMATTING SCRIPT LANGUAGE V1.4 ............ 70
  17.1 Purpose ..................................................................................... 70
  17.2 Language introduction .............................................................. 70
  17.3 Language example ..................................................................... 70
  17.4 Bit function examples ............................................................... 71
  17.5 Operators and reserved words .................................................. 71
<table>
<thead>
<tr>
<th>Section</th>
<th>Title</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>17.5.1</td>
<td>Operators</td>
<td>71</td>
</tr>
<tr>
<td>17.5.2</td>
<td>Reserved words</td>
<td>72</td>
</tr>
<tr>
<td>17.6</td>
<td>Field Identifier</td>
<td>72</td>
</tr>
<tr>
<td>17.7</td>
<td>Decoding of ModBus</td>
<td>74</td>
</tr>
<tr>
<td>17.7.1</td>
<td>Data format for VDR configured as ModBus slave</td>
<td>74</td>
</tr>
<tr>
<td>17.7.2</td>
<td>Data format for VDR configured as ModBus master</td>
<td>76</td>
</tr>
<tr>
<td>17.7.3</td>
<td>ModBus functions</td>
<td>76</td>
</tr>
<tr>
<td>17.7.4</td>
<td>Overlap between input/holding registers and coils/discrete input</td>
<td>79</td>
</tr>
<tr>
<td>17.8</td>
<td>Other functions</td>
<td>79</td>
</tr>
<tr>
<td>17.8.1</td>
<td>Last function</td>
<td>79</td>
</tr>
</tbody>
</table>

APPENDIX A S-VDR CONNING DISPLAY DEFAULT CONFIGURATION | 81
1 Scope and purpose
User manual for VDR Explorer

1.1 References

1.2 Terms and Abbreviations
## 2 System overview

The VDR Explorer is an application designed for W2000, XP or Vista. The VDR Explorer is able to replay data recorded by a Voyage Master II/III S-VDR and VDR. The VDR Explorer can read data from the following sources:

<table>
<thead>
<tr>
<th>Source</th>
<th>Hardware required</th>
</tr>
</thead>
<tbody>
<tr>
<td>Capsule</td>
<td>Data from the capsule that has been removed from the VDR</td>
</tr>
<tr>
<td></td>
<td>- A PC with Firewire port.</td>
</tr>
<tr>
<td></td>
<td>- Firewire repeater with CAT 5 interface</td>
</tr>
<tr>
<td></td>
<td>- A mains to 12V DC adapter for the repeater is needed if a portable PC with 4-pin i/f is used</td>
</tr>
<tr>
<td>Voyage Master II VDR data disc</td>
<td>Data from a backup disc that has been removed from the VDR (Note 1)</td>
</tr>
<tr>
<td>(Hard drive)</td>
<td>- A stationary PC with a 6-pin Firewire port.</td>
</tr>
<tr>
<td></td>
<td>- A Firewire repeater and a mains to 12V adapter is needed when a portable PC with a 4-pin Firewire port is used</td>
</tr>
<tr>
<td>Voyage Master III USB VDR data disc</td>
<td>Data from a USB backup disc that has been removed from the VDR (Note 1)</td>
</tr>
<tr>
<td></td>
<td>- A PC with an USB port</td>
</tr>
<tr>
<td>Data from External Extended backup</td>
<td>- A PC with an Ethernet port</td>
</tr>
<tr>
<td>(NAS)</td>
<td></td>
</tr>
<tr>
<td>VDR Extraction</td>
<td>A file with VDR data downloaded from the VDR, capsule or a backup disc. It may also be a selection of data from another extraction</td>
</tr>
<tr>
<td>Live</td>
<td>Data transferred live from the VDR while recording.</td>
</tr>
<tr>
<td></td>
<td>PC with an Ethernet port (10/100baseT)</td>
</tr>
</tbody>
</table>

Note 1) Data can be retrieved from a functional VDR with the VDR data disc in place by means of the web extractor facility and a PC with an Internet browser/Ethernet port. This is the simplest way of getting access to the VDR data.
2.1 Connecting the PC to a capsule

Stationary PC

<table>
<thead>
<tr>
<th>Firewire cable</th>
<th>6pin - 6pin</th>
</tr>
</thead>
</table>

<table>
<thead>
<tr>
<th>FW repeater CAT5</th>
<th>P/N 1001162</th>
</tr>
</thead>
</table>

<table>
<thead>
<tr>
<th>Crossed CAT5 RJ45 – RJ45</th>
</tr>
</thead>
</table>

Note 2) if the original cable is attached to the capsule, then use a straight CAT5 cable and a RJ45 coupler.

Portable PC

<table>
<thead>
<tr>
<th>Firewire cable</th>
<th>4pin - 6pin</th>
</tr>
</thead>
</table>

<table>
<thead>
<tr>
<th>12VDC</th>
</tr>
</thead>
</table>

<table>
<thead>
<tr>
<th>Mains adaptor</th>
<th>P/N 1001163</th>
</tr>
</thead>
</table>

<table>
<thead>
<tr>
<th>110-240VAC</th>
</tr>
</thead>
</table>

<table>
<thead>
<tr>
<th>Crossed CAT5 RJ45 – RJ45</th>
</tr>
</thead>
</table>

Note 2) if the original cable is attached to the capsule, then use a straight CAT5 cable and a RJ45 coupler.

2.2 Connecting the PC to a VDR data disc (Voyage Master II)

Stationary PC

<table>
<thead>
<tr>
<th>Firewire cable</th>
<th>6pin - 6pin</th>
</tr>
</thead>
</table>

<table>
<thead>
<tr>
<th>Backup disc</th>
</tr>
</thead>
</table>

Note) if the PC is unable to power the disc then use a repeater with a mains adaptor, see below.

Portable PC

<table>
<thead>
<tr>
<th>Firewire cable</th>
<th>4pin - 6pin</th>
</tr>
</thead>
</table>

<table>
<thead>
<tr>
<th>12VDC</th>
</tr>
</thead>
</table>

<table>
<thead>
<tr>
<th>Mains adaptor</th>
<th>P/N 1001163</th>
</tr>
</thead>
</table>

<table>
<thead>
<tr>
<th>110-240VAC</th>
</tr>
</thead>
</table>

<table>
<thead>
<tr>
<th>Crossed CAT5 RJ45 – RJ45</th>
</tr>
</thead>
</table>

<table>
<thead>
<tr>
<th>Backup disc</th>
</tr>
</thead>
</table>

Note) if the PC is unable to power the disc then use a repeater with a mains adaptor, see below.
3 GUI description

3.1 After startup
The VDR Explorer will upon startup use the default configuration (DefaultGuiConfig.xml)

The “window title bar” complies with the general standard for Microsoft GUI. The window title bar will display the name (if defined) of the current GUI configuration.

VDR Explorer window dropdown menus:

File->New: Creates a new (empty) VDR Explorer configuration
File->Open: Opens an existing VDR Explorer configuration
File->Save: Saves the current VDR Explorer configuration using the same name
File->Save as: Saves the current VDR Explorer configuration using a new name
File->Recent files: Short cuts to the 4 most recent configurations, which have been opened or saved on the disc. The configuration, which has been temporary downloaded e.g. from a VDR while playing live will not be included on the list.
File->Exit: Exits the VDR Explorer program.

View->Play control: Displays or hides the play control area.

View->Vessel information: Displays or hides the additional vessel information.

Tools->Log: Displays the log for the VDR Explorer program. This is only used for troubleshooting.

Tools->Audio: Opens the audio settings dialog box.

Tools->Connect: Opens the “connect” dialog box. The “connect” dialog box is used to select a data source for the VDR Explorer see section 7.

Tools->Disconnect: Disconnects the VDR Explorer from the data source.

Tools->VDR config management: The VDR Explorer is able to use information from a VDR configuration object labels see section 6.1.

Tools->VDR Explorer config management: The VDR Explorer is able to store its configuration together with source data and later retrieve this information see section 6.2

Tools->Decoder library: Opens the NMEA decoder library, see section 8.

Tools->Extractor: Opens the Extractor dialog box, see section 9.

Tools->Export Data: Opens the Export Data dialog box, see section 10.

Tools->Setup Serial Output: Opens a dialog box for selecting data to be outputted to other applications, see section 14. (This is only selectable when VDR Explorer in configuration mode.)

Tools->Setup AIS Data Input: Opens a dialog box for selection the common data source for the AIS display objects, see section 15.2. (This is only selectable when VDR Explorer in configuration mode.)

Options->Color Definitions: Opens the definitions dialog box, see section 5.9.

Options->Preferences: Opens the dialog box for setting the program preferences.

Mode->Configuration mode on: Sets the VDR Explorer in configuration mode.

Mode->Configuration mode off: Exits the VDR Explorer from configuration mode.

Monitor: Queue monitor used for troubleshooting only.

3.1.1 Tool bar
The tool bar contains short cuts (presented as icons) to the most common tools and functions.
3.1.2 VDR Explorer status bar
The VDR Explorer status bar contains information regarding the current status of the VDR Explorer. Additional information regarding an object selected by the cursor (“on hover”) may be displayed to the left.

3.1.3 VDR Explorer play control area
The VDR Explorer play control area contains the main controls i.e. play, stop and pause. Some of the controls will be grayed out depending on the data source for the VDR Explorer. See also section 4.1.1
4 Replay of data, short guide

The VDR Explorer will automatically display the “Connect” dialog box when the program is started. This dialog is used for selecting a data source.

To select a data source press “Connect”, consult section 7 for more details.

It is highly recommended that a VDR explorer configuration that matches the VDR data is uploaded to the VDR when the VDR is installed, since this will enable any PC with the VDR Explorer installed to replay data without any configuration work. If this dialog box appears then answer “Yes”. 
4.1.1 Play control
The play control area contains the functions needed for replaying data. Two views are available, simple and advanced.

Simple play control

Advanced play control

A tool tip with helpful information will appear if the cursor hovers over a button for short period. Note) The tool tip is not available for disabled functions (buttons with symbols).

4.1.2 Tracks
A track is defined as an uninterrupted recording session. The VDR will create a new track if it is restarted. VDR data retrieved from a normally operating VDR will only contain one track.

4.1.2.1 Goto button
The “Goto” button will, if activated, set the slider to the position indicated in the input field below the button. A new value may be entered into the input field. The field will become red if the entered value is illegal or out of range. The icon left to the “Goto” button may be used to update the input field with the current position of the slider. This function may be used while the VDR Explorer is playing data. If you want to set a “mark” at an event you want to revert to, do the following. First click on the icon (left to the “Goto” button) to set the “mark”, later click on the Goto button and then “Play”.

4.1.2.2 Action at end of track
It is possible to define one of the following actions when the end of the track is reached.

<table>
<thead>
<tr>
<th>Action</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Stop</td>
<td>Stop playing when end of track reached.</td>
</tr>
<tr>
<td>Continue</td>
<td>Continue to next track if present when end of track reached.</td>
</tr>
<tr>
<td>Repeat 1</td>
<td>Repeat current track when end of track reached.</td>
</tr>
<tr>
<td>Repeat All</td>
<td>Continue to next track if present else play track 1.</td>
</tr>
</tbody>
</table>
5 Configuration

The VDR Explorer must be in confirmation mode “Mode->Configuration Mode - On” before any change of configuration can be made.

5.1 Creating a new configuration

File->New
Will create a new “empty” configuration.

File->Open
Is used to open an existing configuration e.g. a template. Use “File-Save as” to store the new configuration under another name.

5.2 Adding new tab pages

Right click on a tab for and existing page and then click on “Tab properties” and the “Tab page organizer will appear.
5.2.1 Tab page organizer

The “Tab page organizer” is a tool for creating, deleting, hiding, naming and sorting the tab pages.

Click on “Add” and this menu will appear

Type in the title for the new tab page, select a template from the list box and click on “OK”.

9200266-16 Page 16/81
5.3 Creating and moving graphical objects

The graphical objects on a tab page are organized in panels (columns). A graphical object often contains many elements hereafter called gauges.

A proper tab page must be created before any graphical object can be created. Templates with one to four panels and one example have been made. (Right click on any tab for a tab page and then select “Tab properties” opens the “Tab Page Organizer” see section 5.2.

A new graphical object is created on a panel by right clicking on a panel and then “Insert Object”. More objects within a panel will form a column.

The position of an object within a panel may be changed i.e. the object may be moved up and down. Right click on the object and then click on “Object…-> Move up” or “Object…->Move down”

A graphical object cannot be moved to another panel i.e. to the left or to the right. However there is a way around this limitation.

1. Create a new instance of the object that has to be moved on the desired location.
2. Copy the configuration from the original object and paste it onto the new object (see section 5.4.1).
3. Delete the original object.

5.3.1 Creating and moving panels

Right clicking on an existing panel and then select “Insert Panel” will create additional panels. More features for manipulating panels are found by right clicking on an existing panel and then selecting “Panel Properties”

5.4 Configuration of graphical objects

A graphical object contains one or more gauges for displaying data. The only exceptions are the “Numeric data display”, which contains 3 “objects” for displaying data in numerical form or as text and the Paper strip object that is able to display serial data as text.

The following graphical objects have been defined (consult section 15 regarding objects related to AIS data display):

- Dial meter
- Dual dial meter
- Four Vertical bars
- Two Horizontal bars
- Compass dial
- Horizontal ruler
- Doppler log indicator
- Dual Rudder indicator
- Graph
- Roll and Pitch indicator
Right clicking on the object while the VDR Explorer is set into configuration mode opens the property dialog box for a graphical object.

The first tab page called “General” contains the most common parameters for a graphical object. This page is slightly different for the “Numeric data display” see section 5.6.

**Title:** Text that is common for the gauges displayed by the graphical object.

**Gauges:** Checkboxes for enabling/disabling the display of gauges defined for that graphical object.

**Frame:** The boundary of a graphical object is indicated (default) with four thin lines. A number of graphical objects may be grouped by removing the adjacent lines. This is purely a visual effect. A line may be disabled/enabled by double clinking on its position on the squared symbol located in this section.

**Source labels:** (dial meter object only): The label for the fields that displays the data in numeric form

The remaining tab pages are used for configuring the gauges defined for the graphical object.

### 5.4.1 Copy/past of graphical object configuration

The configuration from a graphical object may be copied and pasted onto another identical graphical object.

**Copy configuration:**
Right click on the object with the desired configuration, and then click on “Copy Config”.

**Paste Configuration:**
Right click on the object that needs a new configuration, and then click on “Paste Configuration”. The receiving graphical object must be identical to the original.
5.5 Configuration of Gauges

5.5.1 Dial meter

5.5.1.1 Labels
Dial Title: Text located immediately over the dial meter.

Unit: Text located inside the dial.

Use Peak Indicator: The peak indicator will show the maximum reading for a specified time (peak timeout). This is useful e.g. when measuring wind speed.

5.5.1.2 Scale
This section contains the parameters for controlling the geometry and resolution of the dial.

Start value: The start value corresponds to the most counterclockwise point on the dial.

End value: The end value corresponds to the most clockwise point on the dial.

Format: Format is used to define the format of the figures on the dial, see section 5.10.

Show Mathematical Sign: The parameter controls whether figures on the dial are displayed signed or unsigned.

Angle: Defines the extent of the dial.

Rotation: The dial will per default be oriented like a typical speedometer in a car i.e. the axis of symmetry is vertical. The orientation may be changed by entering a value other than 0 in this field.

Resolution: This parameter controls the graduation of the dial.
5.5.1.3 Sources

**Primary:** Input to the pointer for the dial meter.

**Secondary:** Input to the secondary indicator for the dial meter. The secondary indicator is shown as a small triangle. The secondary indicator is typical used for displaying the “commanded value” while the main indicator shows the actual value.

The “setup” button will open a dial box where the source data can be defined, see section 5.8

5.5.1.4 Colors

Parameters in this section control the appearance of the dial meter. The “set default” may be used to reset all the colors to the default settings (see section 5.9)
5.5.2 Vertical bar

5.5.2.1 Labels
A vertical bar has two labels one at each end. One of them is typically used as description while the other for indicating the unit of measurement.

5.5.2.2 Scale
Start Value:
The start value corresponds to the bottom of the bar.

End Value:
The end value corresponds to the top of the bar.

Mirror Horizontally:
Two adjacent bars are (default) two symmetrical instances i.e. bar 1, 2 and 3, 4 form a pair. This may be changed by checking “Mirror Horizontally” for bars with e.g. odd number.

Format:
Format is used to define the format of the figures for the bar, see section 5.8.3.2.

Show Mathematical Sign:
This parameter controls whether figures for the scale for the bar are displayed signed or unsigned.

5.5.2.3 Sources
Primary:
Input to the main indicator for the bar.

Secondary:
Input to the secondary indicator for the object. The secondary indicator is shown as a small triangle. The secondary indicator is typically used for displaying the “commanded value” while the bar shows the actual value.

5.5.2.4 Colors
Parameters in this section control the appearance of the bar object. The “set default” may be used to reset all the colors to the default settings (see section 5.9)
5.5.3 Horizontal bar

The parameters for the horizontal bar correspond to the parameters for the vertical bar. An extra label (middle) has been added.
5.5.4 Compass dial

5.5.4.1 Scale

Format:
The format is used to define the format of the figures on the compass dial, see section 5.8.3.2.

5.5.4.2 Sources

Primary:
The primary data source controls the rotation of the compass dial, the typical input is “Heading”.

Secondary:
The secondary (optional) data source controls a small triangle circling the compass dial. The typical secondary input is “Commanded Heading”.

5.5.4.3 Colors

The parameters in this section control the appearance of the compass dial. The “set default” button can be used to reset all the colors to the fault settings (see section 5.9)
5.5.5 Horizontal ruler

5.5.5.1 Labels
A vertical bar has 6 labels.

5.5.5.2 Scale
Star value:
The start value corresponds to the far left point of the ruler.

End value:
The end value corresponds to the far right point of the ruler.

Format:
Format is used to define the format of the figures on the ruler, see section 5.8.3.2.

Show Mathematical Sign:
The parameter controls whether the figures on the ruler are displayed signed or unsigned.

5.5.5.3 Sources
Primary:
Input to the primary indicator for the ruler. The main indicator is shown as a triangle above the ruler.

Secondary:
Input to the secondary indicator for the ruler. The secondary indicator is shown as a triangle below the ruler. The secondary indicator is typically used for displaying the “commanded value” while the primary indicator shows the actual value.

5.5.5.4 Colors
Parameters in this section control the appearance of the ruler. The “set default” can be used to reset all the colors to the default settings (see section 5.9)
5.5.6 Doppler log

5.5.6.1 Numeric Output
Unit:
Text displayed after numeric outputs e.g. KNT.

Format:
Format is used to define the format of the numeric outputs, see section 5.8.3.2.

Show Mathematical Sign:
The parameter controls whether the numeric outputs are displayed signed or unsigned.

5.5.6.2 Sources
4 inputs may be applied to the Doppler log object.

Longitudinal Speed:
Is shown as numeric data in the center of the object

Stern Transverse Speed:
Is shown as numeric data at top of the object.

Aft Transverse speed:
Is shown as numeric data at bottom of the object.

Relative Wind Direction:
Is shown as a triangle circling the center of the object.

5.5.6.3 Colors
Parameters in this section control the appearance of the object. The “set default” can be used to reset all the colors to the default settings (see section 5.9)
5.5.7 Rudder indicator

5.5.7.1 Labels
Title:
Text shown beneath the rudder indicator.

5.5.7.2 Scale
Rudder Max Angle:
This parameter controls the extent of the dial for the rudder indicator. It is recommended that a value equal to the maximum rudder angle for the vessel is used.

Show Mathematical Sign:
The parameter controls whether figures on the dial are displayed signed or unsigned.

5.5.7.3 Sources
Primary:
The primary data source controls the pointer; the typical input is data from the rudder angle sensor.

Secondary:
The secondary (optional) data source controls a small triangle circling the dial. The typical secondary input is “Commanded rudder angle”.

5.5.7.4 Colors
Parameters in this section control the appearance of the rudder indicator. The “set default” can be used to reset all the colors to the default settings (see section 5.9)
5.5.8 Graph

5.5.8.1 Graph type
This section is used for defining the input to the X-coordinate for the graph object.

Time/Y graphs:
The primary and secondary will be used as Y-coordinate for two independent graphs. The time will be used as X-coordinate for both graphs.

X/Y graph: The primary input will be used for the X-coordinate and the secondary for the Y-coordinate.

5.5.8.2 Resolution
This section is used for defining the resolution of the graph(s). Small values for “Time Span” and “Sample Interval” derive a graph with high resolution while high values derive a graph that covers a large time span.

5.5.8.3 Labels
Label: Labels for the numeric outputs.

Unit: Text displayed after numeric output and Y-axis, X-axis if X/Y graph is selected.

5.5.8.4 Scale
This section is used for defining resolution and format of figures for the Y-axis and the X-axis if X/Y graph is selected.

5.5.8.5 Colors
Parameters in this section control the colors of the graph. The “set default” can be used to reset all the colors to the default settings (see section 5.9)
5.5.9 Roll and pitch indicator

5.5.9.1 Gauge

Title:
Text shown above the gauge.

Type:
Used to select the gauge type (roll or pitch). Roll is default for gauge 1 and pitch is default for gauge 2.

5.5.9.2 Scale

Format:
Format is used to define the format of the numeric outputs, see section 5.8.3.2.

Show Mathematical Sign:
The parameter controls whether the figures on the dial are displayed signed or unsigned.

5.5.9.3 Source

The data source controls the rotation of the ship shaped indicator in the middle of the gauge; the typical input is data from the roll and pitch sensor respectively.

5.5.9.4 Colors

Parameters in this section control the appearance of the object. The “Set to Default” can be used to reset all the colors to the default settings (see section 5.9)
5.5.10 Azimuth Thruster

5.5.10.1 Parameters for vertical bar
The azimuth thruster object includes a vertical bar to the left. The parameters for this gauge is described in section 5.5.2

5.5.10.2 Thruster
Title: Text located over the dial and the alpha numeric field located right top.

Unit:
Unit for the alpha numeric field located right top.

Use Sin/Cos input:
Mark the checkbox if the thruster utilizes a sinus/cosinus interface for signaling the angle of thrust

Rotation:
The orientation of the dial is controlled by this parameter.

Scale:
Scale may be set to either 0-360° or -180° to 180°.

Scale resolution:
This parameter controls the graduation of the dial.

Format:
Format is used to define the format of the figures in the alpha numeric field located right top, see section 5.8.3.2.

Show Mathematical Sign:
The parameter controls whether figures on the dial are displayed signed or unsigned.

5.5.10.3 RPM
This section contains the parameters for the alpha numeric field located left center.

5.5.10.4 Order
This section contains the parameters for the alpha numeric field located left bottom.
5.5.10.5 Sources
This section is used for defining the input(s) to the thruster symbol and the two alpha numeric fields “RPM” and “Command”.

5.5.10.6 Colors
Parameters in this section control the appearance of the thruster symbol and the two alpha numeric fields “RPM” and “Command”. The “Set to Default” can be used to reset all the colors to the default settings (see section 5.9)
5.6 Numeric data display

5.6.1 General
The Numeric Data Display does not display any gauges. Three smaller “objects” for displaying numeric data or text are displayed instead. These smaller “objects” are called “Alphanumeric data fields. Two sizes exist (large and small).

5.6.2 Colors
The color of the label text for a “Numeric data display” is determined by the default color definition (Text/Outline Color) see section 5.9. The “Primary indicator color” is used as color for the displayed data.

5.6.3 Concatenation
A number of Numeric Data Displays may be concatenated by removing adjacent lines (see section 5.4).
5.7 Paper strip

The Paper strip object is designed to display serial data as text e.g. data that is sent to a line printer. It can also be used to monitor NMEA data.

5.7.1 Data format

The object is able to display data using three different formats:

- ASCII
- NMEA
- Binary. Binary is displayed as “hexadecimal”
5.8 Configuration of data sources for objects
This dialog box is common for all gauges and for the alphanumeric data display with few exceptions. This dialog is opened by clicking on the “Setup” button located in the “Source” section on the property pages for an object.

5.8.1 Source
The source section is used to select the proper source for the gauge. A gauge/data field may be disabled by selecting “No Source” i.e. no other parameters will be forgotten if already configured.

5.8.2 Use replay calibration (gauge only)
A factor (multiplier) and offset may be applied to the original data. E.g. knots may be converted to m/s.

5.8.2.1 Add to log (alphanumeric data field only)
The information displayed in the data field will also be added to the log if this box is checked (see section 12).
5.8.3 Settings for analog data (alphanumeric data field only)

5.8.3.1 Heading and trailing text:
Heading and trailing text may be configured to change according to the numbering value for data.

5.8.3.2 Formatter string
See section 5.10.

5.8.3.3 Test data format
A “test utility” is located beneath the configuration fields.

5.8.4 Settings for digital data

5.8.4.1 Use alternative values (gauge only)
Used to define alternative numeric values for active and inactive state, default (if box is unchecked) is 1 and 0.

5.8.4.2 Use text from VDR configuration
These parameters are used to define what text is associated to active and inactive state e.g. “Open” and “Closed”. This information is normally available from the VDR configuration and can be used by the VDR Explorer as it is.
5.8.5 Setting for serial data

5.8.5.1 Decoding section
Contains information about the currently selected decoder script:

Edit: will open the decoder script editor. The editor is used for creating a new decoder script or for editing the currently selected one. An “*” after the name denotes that the decoder has been edited but not yet stored in the library. But it is strongly recommended that an edited decoder always be given a new name and that the modification is described!

Edit: Will open the decoder editor, see section 8.3.

Save in library: Will save the decoder script in the library if it has been changed. See section 5.8.6

Library: Will open the decoder script library from where the most commonly used decoder scripts can be selected see section 8.

Use checksum: NMEA strings not containing correct checksum information will be ignored if this box is checked.

Use timeout: The appearance of gauge/data field will be affected when no new data is received within a specified time, if this box is checked.

- For gauges
  The indicator will disappear.

- For alphanumeric data field:
  An additional menu “Action” is displayed for an alphanumeric data field. The following actions have been implemented:
  - Delete data: The data field is blanked
  - Dimming: Dimming of the text in the data field
  - Timeout: “Timeout” will be displayed in the data field
5.8.6 Relation between decoders stored in the library and the configuration

Step 1) Decoder #2 is selected for Gauge #1
Step 2) Decoder #3 is selected for Gauge #2
Step 3) Decoder #4 is selected for Gauge #3
Step 4) the decoder for gauge #3 is modified for some reason.
There are now two options:
Step 5a) Store the new decoder under a new name in the library i.e. use the “Save library” function see section 5.8.5.1.
Step 5b) leave at it is i.e. a new decoder is created but is not stored in the library.
This message will appear if attempting to replace a decoder that is not stored in the library.

5.8.7 Alarm settings
Parameters relevant for the alarm display see section 13
5.9 Default color definition

The global colors define the overall color-scheme used for the graphical data display(s).
- The background color is the color of the window used for a graphical data display. The background color will be visible because there is a small space between objects (unless they are merged).
- The Object Frame Color indicates the border of an object.
- Object background Color is background color used for objects.
- “Text/Outline color” is color for static text (e.g. labels) and for outline of most gauges.

Changes to Global color take affect immediately after “OK” or “Apply” is selected even when the VDR Explorer is not in configuration mode.

The default colors are the colors of dynamic elements in a graphical data display e.g. the indicator for a dial meter. Changes to default colors will only take affect for new objects. The colors for an existing object may be set to new default colors by right clicking on the object (in configurations mode) and select Object->Set to Default Colors.
5.10 **Formatter syntax**

Figures displayed in an alphanumerical data field may be formatted, i.e. the number of digit after the decimal point and leading zeroes may be defined.

The formatter syntax is identical to the syntax defined for formatting output from a NMEA decoder.

E.g.: The figures 7.5 and 10 will be displayed like this depending on the formatter.

<table>
<thead>
<tr>
<th>Formatter</th>
<th>7.5</th>
<th>10</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>7</td>
<td>10</td>
</tr>
<tr>
<td>0.0</td>
<td>7.5</td>
<td>10.0</td>
</tr>
<tr>
<td>000</td>
<td>007</td>
<td>010</td>
</tr>
</tbody>
</table>
6 VDR and VDR Explorer configuration management

The VDR Explorer will use information from both the VDR configuration (if available) and a VDR Explorer configuration. The VDR configuration contains useful information about what is connected to the VDR. Information from the VDR configuration may enable the VDR Explorer to e.g. use the name “SI02 Input from GPS” for serial input port #2 rather than just the default name “SI02”.

These functions are normally not needed except for “Tools->VDR Explorer config management->Save VDR Explorer-configuration to source”. This function is used for storing the final VDR Explorer configurations in the capsule. This will enable any PC with the VDR Explorer installed to replay data from that VDR correctly.

6.1 VDR configuration management

Tools->VDR config management->Load VDR configuration from file
Facilitates load of an alternative VDR configuration from a file.

Tools->VDR config management->Load VDR configuration from source
Reloads the original VDR configuration from the source.

Tools->VDR config management->Set VDR configuration to default
Restores the VDR configuration to default i.e. all labels will hereafter correspond to what is printed on the data interface modules e.g. “SI02”.

Tools->VDR config management->Save VDR configuration from source to file
Saves VDR configuration present on the source to a file.

Tools->VDR config management->Save VDR configuration from source to HTML file
Saves VDR configuration present on the source to a HTML file.

Tools->VDR config management->Display VDR configuration from source
Displays the VDR configuration found at the source to which the VDR Explorer is currently connected.

6.2 VDR Explorer configuration management

A few special commands related to VDR Explorer configuration management are included here. Commonly used commands like Open, Save etc. are included in the “File” dropdown menu.

Tools->VDR Explorer config management-> Load VDR Explorer-configuration from source
Tool for reloading of a VDR Explorer configuration from the data source
1) VDR (live playing): The configuration stored in the capsule will be loaded.
2) Capsule/backup disc: The configuration stored in the capsule/on the backup disc will be loaded.
3) Extracted data: A dialog box will enable the user to load the original or the user defined configuration.

Tools->VDR Explorer config management-> Save VDR Explorer-configuration to source
Tool for saving the VDR Explorer configuration at the data source.
1) VDR (live playing): The current VDR Explorer configuration is stored in the capsule and on the backup disc via the VDR. The VDR Explorer must be connected as “Master”.

2) Capsule/backup disc: The VDR Explorer is not able to write to a capsule/backup disc and is consequently not able to save the VDR Explorer configuration at the source if data source is a capsule/backup disc.

3) Extracted data: It is possible to store a “user defined” configuration together with the extracted data. The original VDR Explorer configuration (if present) will not be overwritten.
7 Connect dialog box

Tools->connect will open the connect dialog box.

![Connect dialog box](image)

The connect dialog box is used for connecting the VDR Explorer to a data source. Five types of data sources are supported:

- A capsule
- A backup disc
- VDR extraction
- Live from a VDR

The connect dialog box will change according to the selected type of data source.

7.1 Capsule

“Capsules online” window:
The “Capsules online” window displays a small symbol for each capsule, physically connected to the VDR Explorer PC via the Firewire interface. A capsule is selected by left clicking on its symbol. (Note: It is unusual to connect more than one capsule, but up to three capsules may be connected simultaneously if needed)

“Refresh” button:
Forces the VDR Explorer to scan the Firewire for capsules and update the window.

“Analyze” button and “track information” window:
The selected capsule may be analyzed for its content. The result is displayed in the “track information window”. For more information about tracks consult section 9.1.1
“Connect” button:
Establishes a connection from the VDR Explorer software to the selected capsule. This may take a few seconds.

“Cancel”
Closes the window.

7.2 Backup
Two kinds of backup discs are recognized:
- A disc that has been removed from a VDR
- Disc with data made by the VDR Remote backup utility (large backup)

The dialog for connecting a Backup Disc corresponds to the dialog for connecting a capsule, described in section 7.1.

7.3 VDR extraction
“Browse” button:
Will open a standard file browser dialog box, which is used to locate and open a file containing a VDR extraction (file extension is .vee).

“Analyze” button and “track information” window:
The selected file may be analyzed for its content. The result is displayed in the “track information window”. For more information about tracks consult section 9.1.1.

“Connect” button:
Connects the VDR Explorer to the selected database.

“Cancel” button:
Closes the “Connect dialog” window.

7.4 Live
“Connect to IP” field:
The IP address of the VDR must be entered here.

“Get information” button:
Tests the connection to the VDR with the IP address displayed in the “Connect to IP” field. Status information from the VDR will (if the tested VDR is online) be displayed in the VDR “Information field”.

“Connect” button:
Connects the VDR Explorer to a VDR with the IP address displayed in the “Connect to IP” field.

“Cancel” button:
Closes the “Connect dialog” window.
8 Decoder library

The NMEA decoder library is used to organize the NMEA decoders. A NMEA decoder is a small script, which describes how information shall be decoded and retrieved from a specific NMEA sentence. The syntax for the script language is described in section 17. A short description is available under “Help->Help Topics” in the decoder editor.

Tools->decoder library will open the decoder library.

8.1 Properties for a NMEA decoders

Sentence formatter:
A NMEA decoder is only able to retrieve information from one specific NMEA sentence. A typical NMEA decoder is only able to retrieve information from one field in a NMEA sentence. Most NMEA sentences contain many fields; hence a number of decoders may be needed for retrieving all the information from one sentence.

Decoder group:
A NMEA decoder belongs to a group; all decoders in the same group are stored in the same folder. Groups have been defined corresponding to the data items to be recorded (IEC 61996 section 4.6) e.g. speed (4.6.3) or heading (4.6.4). The user may establish new groups.

Decoder name:
A decoder must be assigned a name. The name must be unique within the decoder group.
(Write) protected decoders:
A number of standard decoders (protected decoders) have been defined. These decoders are write
protected and cannot be changed or deleted. However it is possible to use one of these decoders as a
template for a new decoder.

Sub library file:
The VDR Explorer will at startup “compile” the library from a number of library files each
containing a number of decoders. The standard decoders are stored in one file and another file is
used to store the user-defined decoders. More library files for specific purposes may be added.

Decoder output:
The output from a decoder may behave like analog data, digital data or a text string. This
information may be described for a decoder. However this information is only informative and will
not be used by the VDR Explorer.

8.2 NMEA decoder library window

8.2.1 Drop down menus

File->import:
Imports decoders from an external file. The imported decoders will be added to the user defined sub
library file.

File->export:
Exports decoders to an external file.

File->Save in library:
Saves decoder in library.

File->Close:
Closes the window. Corresponds to cancel.

Edit->New decoder:
Adds a new decoder to the library.

Edit->New folder:
Adds a new folder to the library.

Edit->Copy:
Makes a copy of the selected decoder.

Edit->Edit:
Opens the decoder edit window.

Edit->Rename:
Renames the selected decoder or folder.
**Edit->Delete:**
Deletes the selected decoder or folder.

### 8.2.2 Decoder library tree

The decoder library tree is shown to the left. The “radio buttons” at the top are used to define how the library is organized.

A pop up menu will appear if the user right clicks on a folder or a decoder. This menu will enable the user to add, rename, copy and delete folders and decoders. For “Import to Folder” consult section 8.2.1

**Note:** It is only possible to create a new “root folder” by right clicking on the empty space beneath the “library tree”.

### 8.2.3 Decoder description

The properties for the selected decoder, are shown in decoder description located to the right in NMEA decoder library window consult section 8.1 for more details.
8.3 NMEA Decoder Editor

The NMEA decoder editor may either be opened from the decoder library or from the settings menu for a gauge/alphanumeric data field.

8.3.1 Drop down menus

**File->Save as:**
Closes the editor window and opens the NMEA decoder library window where the new name and folder (group) may be defined. This item is only present if the editor is called from the NMEA decoder library.

**File->Close:**
Closes the editor window. The user will be prompted for unsaved changes.

**Edit->Undo**
**Edit->Redo**
**Edit->Cut**
Commands for the Editor

**Tools->Insert symbol**
A menu with symbols normally not found on a keyboard will be displayed.

**Help->Help topics:**
A description of the decoder script language will be displayed.

### 8.3.2 Tool bar

A tool bar is located below the drop down menus. The tool bar contains short cuts (icons) to the most commonly used items from the drop down menus.

### 8.3.3 General buttons

**“OK” button:**
Changes made will be stored; the editor window is hereafter closed. The previous version of the decoder is overwritten. It is not possible to overwrite the decoders that are supplied with the VDR Explorer.

**“Cancel” button:**
Closes the editor window, any changes made will be ignored and lost.

**“Save As” button:**
The editor window will close. Changes may be saved using a new name/folder while maintaining the previous version of the decoder. The “Save As” button is only enabled if the editor window is opened from the library (i.e. disabled when opened from the GUI configurator).

### 8.3.4 Decoder information

Decoder name:
See section 8.1

Decoder output:
See section 8.1

Decoder description:
A description of the decoder may be included (recommended).
8.3.5 Editor window
A script defining the decoder shall be entered in the NMEA decoder window. The “sentence formatter field” derives information from the “search for” statement in the decoder script. The full name for the NMEA sentence will be displayed if the sentence formatter is known.

“Help->Help topics” shows a short description of the script language. Section 17 contains an extensive description of the script language.

8.3.6 Decoder test
A decoder may be tested against an NMEA sentence if the test decoder button is activated. Two things happen when the test button is activated:

1. The script will be compiled i.e. the syntax is checked. The text in the “NMEA test sentence” field will not influence this. The test will only continue if the compilation is successful.
2. The NMEA decoder will decode the NMEA sentence shown in “NMEA test sentence” field. This is of course only meaningful if the NMEA sentence formatter in the test sentence matches the NMEA sentence formatter in the decoders search for statement. The data output and the trend output will be displayed upon a successful test.

8.3.6.1 “NMEA test sentence” field
The user may enter a test sentence in this field. Copy/paste from e.g. the serial monitor may be used. The 10 most recent test sentences will be saved.
9 Extractor

The Extractor is used to retrieve data from a data source to a database. The VDR Explorer must be connected to a data source (not live from a VDR) before the Extractor tool can be opened.

9.1.1 Track information

The track information for the currently selected capsule or backup disc is displayed in this window. A track is defined as an uninterrupted recording session. This typical corresponds to a time period where the VDR was not interrupted e.g. by a restart. However, other events may divide a recording into two tracks e.g. a bad record (checksum error) on the disc. There will only exist one track in the capsule or on the backup disc for a VDR system that has been running uninterrupted and faultless for more than 13 hours.

One or more tracks must be selected before the extraction process can start. A track is selected by right clicking anywhere on the text line for that track (except on the checkbox). The sliders on the blue bar may be used to reduce the amount of data used from the selected track.
The check boxes are used for indicating whether a track shall be included or excluded from the extraction. Only check marked tracks will be included.

**Extraction target:**
Displays the currently selected (if any) target file for the extraction.

**“Extract” button:**
Starts the extraction process.

**“Close” button:**
Closes the window.

Overview for the extraction process step by step:

1. Connect to a capsule or backup disc using the connect tool.
2. Open the extractor tool.
3. Select and optionally shorten the duration of tracks to be extracted.
4. Define (Browse) the target file for the extraction.
5. Start extraction process using the “Extract” button.

Extracting all data from a capsule will take approximately 20 minutes and require 6G byte of disc space.
10 Data Export Tool

The “Data Export Tool” may be used for exporting the VDR data into either an IEC61996-1/2 compatible format or an open industry format.

<table>
<thead>
<tr>
<th>Data</th>
<th>IEC61996-1/2 format</th>
<th>Open industry format</th>
</tr>
</thead>
<tbody>
<tr>
<td>Audio</td>
<td>Wave files (*.wav)</td>
<td>Wave files (*.wav)</td>
</tr>
<tr>
<td>Images</td>
<td>Bitmap (*.bmp)</td>
<td>Compressed Tiff (*.tif)</td>
</tr>
<tr>
<td>Serial data</td>
<td>One comma separated data file (*.txt)</td>
<td>Text files (*.txt)</td>
</tr>
<tr>
<td>Analog and Digital data</td>
<td></td>
<td>Comma separated files (*.csv)</td>
</tr>
<tr>
<td>Power status</td>
<td></td>
<td>Note 1</td>
</tr>
<tr>
<td>Alarms</td>
<td></td>
<td>Note 1</td>
</tr>
<tr>
<td>System log</td>
<td>Text files (*.txt)</td>
<td>Text files (*.txt)</td>
</tr>
<tr>
<td>Configuration</td>
<td>HTML file (*.htm)</td>
<td>HTML file (*.htm)</td>
</tr>
</tbody>
</table>

Note 1) The separator will be “,” or “;” depending on the regional settings for the VDR Explorer (Options -> Preferences -> Regional Settings)

A data source must be selected before opening the export tool (see section 7). Click on “Tools -> Export data” and data export tool dialog box will open.

Select the data to be exported (checkmark all boxes if all data shall be exported).
Select a folder for the data (Click on “Browse to folder”).

Select whether the export format should be IEC61996-1/2 (“IMO mode” checked) or an alternative open industry (“IMO mode” not checked). For IMO mode is it possible to split the audio files, data file and the system log into smaller more handy files each covering a user definable time span.

Click on “Export”.

**10.1.1 Export raw serial data**

Time stamps for serial data will be omitted if “Export raw data” is selected (radio button to the right). Data from each serial channel will be exported to an individual file.
11 Audio settings tool
The Audio settings tool contains check boxes for selecting and directing audio channels to the left or right speaker.

A master volume is included.

The compression effect is useful when listening to recordings with a high dynamic range.

11.1 Password protected audio
Audio may be password protected i.e. replay of audio disabled unless the correct password is entered. Audio replay may be enabled by opening the Audio Settings Tool and enter the correct password when prompted.

The password is defined by the configuration for the VDR.
12 Data Log

The data log function is able to log data from selected objects into a CSV file. The data log function is associated to a special tab page. The data log tab page is created like any other tab page.

- The VDR Explorer must be in configuration mode.
- Right click on a tab for a tab page and then select “tab properties”, this will open the “tab page organizer”.
- Click on “add” and select the “Data Logger Tab”.

12.1 Configuration of data log

Columns may be created by two methods.

12.1.1 Direct creations of columns

- The VDR Explorer must be in configuration mode.
- Right click on the title bar for the columns next to “Timestamp”.

- Click on “add column” and a list of relevant objects appear.

![Image of Data Log interface]
• Select an object and click on OK

• Enter the title press ok and a new column is created.
12.1.2 Indirect creations of columns

- The VDR Explorer must be in configuration mode.
- Open the properties dialog for an object that is able to input data to the data log (short standard object and standard object).

- Check “Add to log” and a new column is created.

- Change the title if needed. Right click on the title, select “Column Title” and enter a new title.
12.1.3 Organizing columns
The VDR Explorer must be (with few exception) in configuration mode.

Right clicking on the title for column will open a menu with miscellaneous commands.

In general the width and order of the column can be changed in the same manner as for many other Windows programs e.g. using "click, drag and drop" on the column title can be used to rearrange columns.

12.1.4 Maximum number of columns
The maximum number of columns that can be handled depends on the PC. A PC that meets the general requirements for the VDR Explorer will be able to handle 25 columns without any noticeable performance degradation.
12.2 Saving log data to a file

The program will store the data to a user defined output file.

The library path for the log files is defined by the preferences for the VDR Explorer see section 12.3

12.2.1 Max file size

Maximum file size is user defined. Data logging will stop when the file is full. The file may then be reset (or renamed/moved using Windows Explore).

12.2.2 Sample interval

The sample interval is user defined. Fast sampling (small intervals) requires lot of disc space.

12.3 Preferences

12.3.1 Directory path for log files

The library path for the log files are defined by the preferences for the VDR Explorer (VDR Explorer main window, Options->Preferences->Directory settings).

12.3.2 Disable data logging at connect

Data logging without explicit acknowledge can be inhibited (VDR Explorer main window, Options->Preferences->Data Logger).

On: Data logging must be started manually even is a VDR Explorer configuration with “data logger enable” is loaded.

Off: Data logging will start automatically if a VDR Explorer configuration with “data logger enable” is loaded.

Prompt: (Default) the user will be prompted for accept of data logging.
13 Alarm panel

Selecting “Tools->Alarm Panel” or clicking on the icon on the Player window tool bar will activate the alarm window.

![Alarm Display]

**Acknowledge all alarms:**
This function will acknowledge all alarms on the list. An alarm may be acknowledged individually by clicking on the icon for that alarm.

**Delete all alarms:**
The function will delete all alarms from the list. An alarm may be deleted individually by clicking on the icon for that alarm.

**Acknowledge audio:**
This function will mute the audio until a new alarm is generated.

**Options->Disable sound:**
This option will mute the audio related to the alarms panel completely.

**Options->Disable popup:**
This option will prevent the alarm window from popping up when a new alarm is generated.
13.1.1 Easy localization of alarms source
Double clicking on the text for an alarm will bring the tab page from where the alarm is generated to the front.

13.2 Default setting for alarm panel
The default settings for the alarm panel may be set from the Player’s main window by selecting “Option->Settings”.

![Preferences window showing alarm sound settings](image)
13.3 Configuration of objects for alarms

Most objects can generate an alarm to the alarm panel.

The parameters for generating alarms are located together with the other parameter related to a data source see section 5.8.

The example above shows how an alarm will be generated if the wind speed is above 23knt.

**Active:**
The object will only generate alarms if this box is checked.

**Alarm text:**
The text that will be written in the alarm window.

**Level Alarm:**
An alarm will be generated if the output is above or alternatively under a specific level.
For serial communication, please note that the trend output from a NMEA decoder is used for the alarm system.

**Alarm on new data:**
An alarm will be generated every time data is received (only applicable for serial data).
14 Relay of serial output to other applications
The VDR Explorer is able to relay serial data to other applications.

14.1 Output port settings
An output port on the PC for the serial data is needed and must be configured. These parameters are included in the VDR Explorer’s preferences (Options->Preference->Port Settings).
14.2 Configuration of serial output
The VDR Explorer must be in configuration mode.
A click on “Tools->Setup Serial Output” will open the tool for configuring the sources of the serial output.

14.2.1 Merging of data
The program is designed to handle NMEA sentences i.e. two sentences will not be interleaved but sent one at a time. The program may fail to relay ASCII or binary data correctly depending of the properties of the data.

14.3 Enable/Disable output
An icon on the VDR Explorer tool bar can be used to enabled/disable the serial output. This can be done while the VDR Explorer is playing/replaying data.
14.4 Overflow on serial port
The serial output port may overflow if the combined inputs exceed the capacity of the output port. The warning may be displayed if this happens. It is possible to suppress the message. This will be in force until output is disabled and then enabled.

14.5 Serial output and step
The VDR Explorer is able to generate serial output while stepping. However the output port may be congested and steps may take very long time to process.
15 AIS data display

There are eight objects designed for displaying AIS data:

- AIS display
- AIS display (small)
- AIS own ship info
- AIS target info
- AIS target list (.5x1)
- AIS target list (.5x2)
- AIS target list (1x1)
- AIS target list (1x2)

The figures following an “AIS target list” refer to the size of the object where 1x1 is the typical size of a graphical object.

Notice that AIS data display object may be mixed with other objects on a tab page.

15.1 AIS display tab

A default AIS data display has been defined, which contains a useful combination of AIS objects. This tab page is created like any other tab page, see section 5.2.
The AIS tab page is composed of the following objects:

- One AIS display
- One AIS Own ship info
- Four AIS target Info
- One AIS target list (.5x2)

15.2 Selecting data source

“Tools->Setup AIS Data Input” will open the “AIS data settings” tool.

Select the serial channel to which the AIS is connected.
15.3 Using a AIS display tab

The most important feature of the AIS data display is the ability to assign a label to and get information about a target of interest. This is simply done by clicking either directly on the target on the AIS display or on the label field for the target in the AIS target list. An AIS target info object will be assigned to the target when this is done.

E.g.: On the AIS display tab shown above targets “A” and “B” have been selected.

A target may be deselected by clicking on the target again. The number of “AIS target objects” on an “AIS display tab” determines the number of targets that can be selected simultaneously. “First in first out” applies if the number of selected targets exceeds the number of “AIS target objects”.

15.4 Symbols for Targets

AIS Standard target:

Base station:
Aids to navigation:

Aircraft:

15.5 Supported messages

1 - Position report
2 - Position report
3 - Position report
4 - Base station report
5 - Static and voyage related data
6 - Binary addressed message
8 - Binary broadcast message
9 - Standard SAR aircraft position report
12 - Addressed safety related message
14 - Safety related broadcast message
18 - Standard Class B equipment position report
19 - Extended Class B equipment position report
21 - Aids-to-navigation report
22 - Channel management
24 - Class B "CS" static data report
16 Special features

16.1 Floating windows
Note: This new feature has been designed for experienced users. Using floating windows in configuration mode may be confusing.

A tab page may be detached from the VDR Explorers main window. This is either done by “click, drag and drop” or “double clicking” on the tab for a tab page.

Right clicking on the top bar for a floating window will open a menu with items for manipulating the window e.g. making it full screen.

Double clicking on the top bar for floating window will revert the window to a tab page. A floating window will also revert to a tab page if the corner of the window is aligned with the corner first tab in the VDR Explorer’s main window.

16.1.1 “Windows” drop down menu
A drop down menu (Windows) has been added to the menu bar for the VDR Explorers main window. The window selected from this menu will be brought to the front.

16.2 Support for PC’s with lower screen resolution
The VDR Explorer is designed for 1280x1024 and above, however a PC with lower screen resolution may be used with minor inconvenience.

16.3 Vessel information
Complete vessel information is normally not displayed. “View->Vessel information” may be used to open/close a window for displaying complete vessel information. One “data item” related to Vessel information (vessel name is default) is displayed next to the tool bar for the VDR Explorer’s main window.

16.4 Play control
“View->Play Control” may be used to hide/show the Play Control. The Play Control may also be moved around (click, drag and drop).

16.5 Full screen radar image
Full screen radar image is entered and exited by double clicking on the image.

16.6 Full screen graph object
A double click on a graph object will expand it to full screen. A full screen graph will return to normal size upon a double click.
17 NMEA sentence formatting script language V1.4

17.1 Purpose

The purpose of this language is to easily match a given NMEA sentence and format it to human readable text. This implies that both pattern matching ability and string formatting ability must be a part of the language. The resulting human readable text will have a value associated with it. This value is used for the trend indicator and is most likely taken from the NMEA sentence.

17.2 Language introduction

Matching and formatting a NMEA sentence consists of applying a small compiled program to a NMEA sentence. The output from this program will be the formatted string and an optional value. In this context a program is a compiled set of statements in the NMEA sentence formatting language. The source for a program in this language consists of a sequence of statements. Each statement will be executed in the order they are written; hence the language is a straight-line language. If a statement fails, the program will exit.

17.3 Language example

The syntax and semantics of the language is best shown by use of an example. For an exact description of the language see the Grammar chapter 3.

The following NMEA sentence is to be formatted:

Field no: |  1  |    2    |3|    4     |5|    6    | 7
Sentence: $GPGLL,5536.1234,N,01244.1234,E,123456.78,A*1B

into the following result: “N 55°36.123” and the associated trend value “5536.1234” . Running the following program does this:

```plaintext
// This is a comment and have no effect on the program
Search for “GLL”
If #7 <> “A”
    print “GPS failed”
    Stop
EndIf
Print #3
Print “ ”
Print #2 1:2
Print “”
Print #2 3:6 F00.000
Trend #2
```

The first line is a comment and has no effect on the program, but can be a useful aid when developing decoders in the formatting language. The second line “Search for “GLL”” identifies which NMEA id this program is valid for. The third line uses an “if“ construct to test if field 7 contains the text “A”. If this is the case, the text “GPS failed” is printed and the program stops. If
not, the program continues onto line three. The next few lines consists of “print” statements on field identifiers and strings. The hash mark “#” indicates a field identifier:

```
#field [range] [format]
```

Where “field” indicates the field number, “range” the range of characters to use and “format” how the number should be formatted.

Continuous “print” operations can be concatenated into one “print” sentence resulting in a more compact program:

```
Search for “GLL”
If #7 <> “A”
   print “GPS failed”
   Stop
EndIf
Print #3 “ “ #2 1:2 “°” #2 3:6 F00.000
Trend #2
```

The last line identifies the field which will be used as the trend value.

### 17.4 Bit function examples

The following fictive NMEA sentence is used:

Field no:  |  1  |  2   | 3| 4
Sentence: $XXXYY,DEADBEEF01,N,A*1B

```
search for "YYY"
if bit(#2,2) = 1
   print "bit 2"
   stop
endif
if bit(#2,1) = 1
   print "bit 1"
endif
```

The output of this program applied to the above NMEA sentence is: “bit 1” since bit 2 is not set. Bit number is counted from the right hand side and begins at position 1. Hence bit 24-28 is the “B”.

### 17.5 Operators and reserved words

#### 17.5.1 Operators

The following operators are valid in “if” statements:

<table>
<thead>
<tr>
<th>Operator</th>
<th>Meaning</th>
<th>Valid types on the right side of operator</th>
</tr>
</thead>
<tbody>
<tr>
<td>=</td>
<td>Equality</td>
<td>Strings, integers and real numbers</td>
</tr>
<tr>
<td>Operator</td>
<td>Description</td>
<td>Notes</td>
</tr>
<tr>
<td>----------</td>
<td>-------------</td>
<td>-------</td>
</tr>
<tr>
<td>&lt;&gt;</td>
<td>Inequality</td>
<td>Strings, integers and real numbers</td>
</tr>
<tr>
<td>&lt;=</td>
<td>Greater or equal</td>
<td>Integers and real numbers</td>
</tr>
<tr>
<td>&gt;=</td>
<td>Less or equal</td>
<td>Integers and real numbers</td>
</tr>
<tr>
<td>&lt;</td>
<td>Less than</td>
<td>Integers and real numbers</td>
</tr>
<tr>
<td>&gt;</td>
<td>Greater than</td>
<td>Integers and real numbers</td>
</tr>
</tbody>
</table>

The left side of an operator must be a field.

### 17.5.2 Reserved words

The following words are reserved:

<table>
<thead>
<tr>
<th>Reserved word</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>Print</td>
<td>Prints a field or a string</td>
</tr>
<tr>
<td>Search for</td>
<td>Identifies the NMEA id the program is valid for</td>
</tr>
<tr>
<td>If</td>
<td>Beginning of an “if” statement. “if” statement cannot be nested.</td>
</tr>
<tr>
<td>EndIf</td>
<td>Identifies that the “if” statement ends here</td>
</tr>
<tr>
<td>Stop</td>
<td>Stop the program keeping result</td>
</tr>
<tr>
<td>Break</td>
<td>Break the program with no result</td>
</tr>
<tr>
<td>Trend</td>
<td>Set trend value</td>
</tr>
<tr>
<td>Bit(Field, Bit no.)</td>
<td>Returns 1 if a bit is set in Field, 0 if not. Field must be a hex string. If bit does not exist it returns −1.</td>
</tr>
<tr>
<td>Mbit(Field, bit no.)</td>
<td>Returns 1 if a bit is set in a ModBus field, 0 if not. Field must be a ModBus string. If bit does not exist it returns −1.</td>
</tr>
<tr>
<td>MREGBIT(#&lt;field no.&gt;,&lt;register no.&gt;,&lt;bit no.&gt;)</td>
<td>Returns the value of the bit in the register if present PDU. Field must be a ModBus string. Returns −1 if the register value is not present.</td>
</tr>
<tr>
<td>Mreg(Field, reg no.)</td>
<td>Returns ModBus register if the register exists in the ModBus field. Field must be a ModBus string. If register does not exist it returns −1.</td>
</tr>
<tr>
<td>MSreg(Field, reg no.)</td>
<td>Returns a signed ModBus register if the register exists in the ModBus field. Field must be a ModBus string. If register does not exist it returns 0. Use Mreg to the register existence.</td>
</tr>
<tr>
<td>Last(Field, count)</td>
<td>Returns the last “count” characters of a field.</td>
</tr>
</tbody>
</table>

Reserved words are **not** case sensitive.

### 17.6 Field Identifier

The hash mark “#” indicates a field identifier:

```plaintext
#field [range] [format]
```

Where “field” indicates the field number beginning from 1.
The “range” is optional and identifies the range of characters to use. The syntax is “x:y” where “x” is the first character to use (unless “y” is negative) and “y” is the number of characters. If “x” is out of range then the program is terminated and an error is printed. If “y” is out of range then the program will print to the end of the field.

If “y” is negative then the characters are selected from left. First to be printed is “x-y+1” and last character to be printed is “x”

Example:

Field no: |  1  |    2     |3| 4
Sentence: $XXYYY,123456,N,A*1B

search for "YYY"
print #2 3:-2

The printed result will be “23”.

If “x” is negative then the first character to print is selected from the right. Example:

Field no: |  1  |    2     |3| 4
Sentence: $XXYYY,123456,N,A*1B

search for "YYY"
print #2 -4:3

This printed result will be “345”.

To print everything but the last two characters of field 2:

Field no: |  1  |    2     |3| 4
Sentence: $XXYYY,123456,N,A*1B

search for "YYY"
print #2 -3:-99

Will print “1234”

The “format” field is optional and similar to the one used in Visual Basic. The maximum length of a formatter will be limited to 10 characters, including the decimal point.

E.g.:

<table>
<thead>
<tr>
<th>Formatter</th>
<th>Data to display</th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>-</td>
<td>14.75</td>
<td>0.336</td>
<td>-17</td>
</tr>
<tr>
<td>F0</td>
<td>14</td>
<td>0</td>
<td>-17</td>
</tr>
<tr>
<td>F00.00</td>
<td>14.75</td>
<td>00.34</td>
<td>-17.00</td>
</tr>
</tbody>
</table>
The will be no default formatting of fields.

By replacing the “F” with an “A” the result will be formatted into an absolute value. The following syntax is not allowed: “F0.” and “F.0”

### 17.7 Decoding of ModBus

The VDR is able to record ModBus communication (this requires VDR software version 2.05 or newer).

The VDR can operate as ModBus slave or master. The format of the data and the corresponding decoders depend on this.

The ModBus data will be encapsulated as NMEA strings before they are stored by the VDR. The sentence formatter is: PMTM<PDU main group><Master flag>

- **PMTM**: Common prefix for all NMEA string related to ModBus encapsulation
- **PDU group**: ModBus defines a number of different commands for read/write of bits and registers. These have been compiled into four groups:
  - **RDB**: Read bit
  - **WRB**: Write bit
  - **RDR**: Read Register
  - **WRR**: Write Register
- **Master flag**: Sentence formatter is terminated by “M” if the string contains data sent to the master i.e. the NMEA string contains a ModBus response

#### 17.7.1 Data format for VDR configured as ModBus slave

The control system (master) will send data to the VDR on a regular basis. Both request from and answers to the control system will be recorded by the VDR. The requests from the control system contain the data of interest while the answers to the control system are informational only.

The control system will in this case use different forms of ModBus write commands i.e. the decoder scripts must search for PMTMWRB and PMTMWRR

Do not make scripts for the responses to the control system if the VDR is configured as ModBus slave i.e. do not search for sentence formatter terminated with an “M”
<table>
<thead>
<tr>
<th>Function code</th>
<th>Sentence formatter for Master request</th>
<th>Sentence formatter for Response from VDR</th>
<th>ModBus Request Format</th>
<th>ModBus Response Format</th>
<th>Recorded response</th>
</tr>
</thead>
<tbody>
<tr>
<td>0x01: READ COILS</td>
<td>RDB</td>
<td>RDBM</td>
<td>2: Address 1: #Bytes, N N: Data</td>
<td>2: Address 1: #Coils N: Data</td>
<td></td>
</tr>
<tr>
<td>0x02: READ DISCRETE IMPUTS</td>
<td>as above</td>
<td>as above</td>
<td>as above</td>
<td>as above</td>
<td>as above</td>
</tr>
<tr>
<td>0x03: READ HOLDING REGISTERS</td>
<td>RDR</td>
<td>RDRM</td>
<td>2: Address 1: #Bytes, N N: Data</td>
<td>2: Address 1: #Reg. N: Data</td>
<td></td>
</tr>
<tr>
<td>0x04: READ INPUT REGISTERS</td>
<td>as above</td>
<td>as above</td>
<td>as above</td>
<td>as above</td>
<td>as above</td>
</tr>
<tr>
<td>0x05: WRITE SINGLE COIL</td>
<td>WRB</td>
<td>WRBM</td>
<td>2: Address 2: Data 2: Address 2: Data 2: Address 2: Data</td>
<td>2: Address 2: Data 2: Data</td>
<td>2: Address 2: Data 2: Data</td>
</tr>
<tr>
<td>0x06: WRITE SINGLE REGISTER</td>
<td>WRR</td>
<td>WRRM</td>
<td>as above</td>
<td>as above</td>
<td>as above</td>
</tr>
<tr>
<td>0x07, 0x08, 0x0B, 0x0C, 0x11, 0x2B: Various diagnostics</td>
<td>DIA</td>
<td>DIAM</td>
<td></td>
<td></td>
<td>As received Not decodable by Player</td>
</tr>
<tr>
<td>0x0F: WRITE MULTIPLE COILS</td>
<td>WRB</td>
<td>WRBM</td>
<td>2: Address 1: #Bytes, N N: Data</td>
<td>2: Address 2: #Coils 2: Address 2: #Coils</td>
<td></td>
</tr>
<tr>
<td>0x10: WRITE MULTIPLE REGISTERS</td>
<td>WRR</td>
<td>WRRM</td>
<td>2: Address 1: #Bytes, N N: Data</td>
<td>2: Address 2: #Reg. 2: Address 2: #Reg.</td>
<td></td>
</tr>
<tr>
<td>0x17: READ/WRITE MULTIPLE REGISTERS</td>
<td>WRR</td>
<td>RDRM</td>
<td>2: Read Addr 1: #Bytes, N N: Read Data</td>
<td>2: Read Addr 2: #Read reg. 1: #Bytes, N N: Read Data</td>
<td></td>
</tr>
<tr>
<td>OTHERS EXCEPTION</td>
<td>OTH</td>
<td>OTHM</td>
<td>EXCM</td>
<td></td>
<td>As received Not decodable by Player</td>
</tr>
</tbody>
</table>
17.7.2 Data format for VDR configured as ModBus master

The VDR will poll the control system (slave) on a regular basis. Both request to and answers from the control system will be recorded by the VDR. The answers from the control system contain the data of interest while the requests to the control system are informational only. The control system will in this case respond to different forms of ModBus read request i.e. the decoder scripts must search for PMTMRDBM and PMTMRDRM. Do not make scripts for the request to the control system if the VDR is configured as ModBus master i.e. search only for sentence formatter terminated with an “M”.

<table>
<thead>
<tr>
<th>Function code</th>
<th>Sentence formatter for VDR Master request</th>
<th>Sentence formatter for Response to VDR Master</th>
<th>ModBus Request Format</th>
<th>ModBus Response Format</th>
<th>Recorded response</th>
</tr>
</thead>
<tbody>
<tr>
<td>0x01: READ COILS</td>
<td>RDB</td>
<td>RDBM</td>
<td>2: Address 2: #Coils 1: #Bytes, N N: Data</td>
<td>2: Address 2: #Coils 1: #Bytes, N N: Data</td>
<td>as above</td>
</tr>
<tr>
<td>0x02: READ DISCRETE INPUTS</td>
<td>as above</td>
<td>as above</td>
<td>as above</td>
<td>as above</td>
<td>as above</td>
</tr>
<tr>
<td>0x03: READ HOLDING REGISTERS</td>
<td>RDR</td>
<td>RDRM</td>
<td>2: Address 2: #Reg. 1: #Bytes, N N: Data</td>
<td>2: Address 2: #Reg. 1: #Bytes, N N: Data</td>
<td>as above</td>
</tr>
<tr>
<td>0x04: READ INPUT REGISTERS</td>
<td>as above</td>
<td>as above</td>
<td>as above</td>
<td>as above</td>
<td>as above</td>
</tr>
</tbody>
</table>

17.7.3 ModBus functions

These functions are only relevant when decoding ModBus data.

MBIT( <field no.>, <bit no.> )

Field number: Always equal to 2 with the current encoding
Bit no.: 0x01 to 0x10000

Purpose: Used for testing the value for a bit in a “write multiple/single coils” command PDU.
Returns 1 if the bit is 1
Returns 0 if the bit is 0
Returns -1 if the bit is not present.

Used as a function in IF and PRINT statements:

SEARCH FOR “PMTMWRB” // (or “PMTMRDBM” if VDR is master)
IF MBIT(#2, 0x0021) < 0  
    // No bit so break without result  
    BREAK  
ENDIF  

IF MBIT(#2, 0x0021) = 0  
    PRINT “off”  
    TREND 0  
ENDIF  

IF MBIT(#2, 0x0021) = 1  
    PRINT “on”  
    TREND 1  
ENDIF  

Used on the following ModBus sentence:

Multiple Coil (write) : $PMTMWRB,010F002000100255551A2F,A*70

Gives the result “on” and trend “1”.

Description:
The specified field must contain a complete ModBus command coded as ASCII characters.  
- The function code must be equal to “0F”, “05”, “01”, “02” (character 3:2).

Read or Write single bit:
The address for the bit must match the “output address”, character 5:4.

Read or Write multiple bits:
- The bit must be within the addressed range i.e. “starting address” to (“starting address” +  
  “quantity of outputs” –1). “Starting address” is character 5:4 and “quantity of outputs” is character  
  9:4

MREGBIT(#<field no.>,<register no.>,<bit no.>)

Used as an operator in IF and PRINT statements.

Field number: Always equal to 2 with the current encoding.  
Register no.: 0x01 to 0x10000  
Bit no.: 0 to 15

Purpose: Used for reading one bit in a register from a write multiple/single register command PDU.  
Returns the value of the bit in the register if present in the PDU  
Returns –1 if the register value is not present  
Generates a compile-time error if bit no. is not within 0..15

MREG(#<field no.>,<register no.>)

Purpose: Used for reading a register from a read/write multiple/single register command PDU.
Returns the value from the register if present in the PDU
Returns –1 if the register value is not present

Used as a function in PRINT and IF statements:

```plaintext
SEARCH FOR "PMTMWRR" // (or "PMTMRDRM" if VDR is master)
IF MREG(#2,0x9c42) < 0
   // No register so break without result
   BREAK
ENDIF
PRINT "Register : " MREG(#2, 0x9c42)
TREND MREG(#2, 0x9c42)
```

Used on the following ModBus sentence:

Multiple Reg (write) : $PMTMWRR,01109C4100030611112222333337616,A*6E

Gives the result “Register : 4369” and trend “4369”. ( 4369 = 0x1111).

Description:
The specified field must contain a complete ModBus command coded as ASCII HEX.
- The function code must be equal to “06”, “10”, “17”, “03” or “04” (character 3:2).

Read or Write register:
The address for the specified register must match the “register address”, character 5:4.

Read or Write multiple registers:
- The specified register must be within the addressed range i.e. “starting address” to (“starting address” + “quantity of registers” –1). “Starting address” is character 5:4 and “quantity of registers” is character 9:4

Read/write multiple registers (0x17):
- The specified register must be within the addressed range i.e. “starting address” to (“starting address” + “quantity of registers” –1). “Starting address” is character 13:4 and “quantity of registers” is character 17:4

**MSREG(#<field no.>,<register no.>)**

Purpose: Used for reading a register from a write multiple/single register command PDU. The MSREG function returns a signed value (two’s compliment) while MREG return the binary value.
Returns the value from the register if present in the PDU
Returns 0 if the register value is not present or if the value is 0, use MREG to test for register existence.

Used as a function in PRINT and IF statements:

```plaintext
SEARCH FOR "PMTMWRR" // (or "PMTMRDRM" if VDR is master)
```
IF MREG(#2,0x9c42) < 0
    // No register so break without result
    BREAK
ENDIF

PRINT "Register : " MSREG(#2, 0x9c42)
TREND MSREG(#2, 0x9c42)

Used on the following ModBus sentence:

Multiple Reg (write) : $PMTMWRR,01109C41000306FFFF222233337616,A*6E

Gives the result “Register : -1” and trend “-1”. ( -1 = 0xFFFF).

Description:  See description for MREG

17.7.4 Overlap between input/holding registers and coils/discrete input
It is not possible to distinguish between input/holding registers and coils/discrete input just using the sentence formatter. The ModBus function code must be decoded for a system that has address overlap for the input/holding registers or coils/discrete input. (This problem is only relevant if the VDR is configured as master)

SSEARCH FOR "PMTMRDRM"
IF MREG(#2,0x9c42) < 0
    // No register so break without result
    BREAK
ENDIF
IF #2 3:2 <> "04"  // Test for read of input registers
    // This is not a read of input register so break without result
    BREAK
ENDIF

PRINT "Register : " MREG(#2, 0x9c42)
TREND MREG(#2, 0x9c42)

17.8 Other functions

17.8.1 Last function
The last function returns the last characters of a field.

The following fictive NMEA sentence is used:

Field no:  |  1  |    2     |3| 4
Sentence: $XXYYY,DEADBEEF01,N,A*1B
search for "YYY"

if last(#2,3) = "F01"
    print last(#2,3)
    trend last(#2,1)
    stop
endif

The printed result will be “F01” and the trend value 1.
## Appendix A S-VDR conning display default configuration

<table>
<thead>
<tr>
<th>Object</th>
<th>Title and Indicator</th>
<th>Input</th>
<th>Enabled/ Disabled</th>
<th>Pre-configured decoder script</th>
<th>Alternative Decoder scripts</th>
</tr>
</thead>
<tbody>
<tr>
<td>Numeric data display, left</td>
<td>UTC Time Object 1</td>
<td>SI02</td>
<td>Enabled</td>
<td>UTC time (ZDA)</td>
<td>UTC time (GGA) UTC time (GLL) UTC time (GNS) UTC time (RMC)</td>
</tr>
<tr>
<td></td>
<td>UTC Date Object 2</td>
<td>SI02</td>
<td>Enabled</td>
<td>UTC date (ZDA)</td>
<td>Date (RMC)</td>
</tr>
<tr>
<td></td>
<td>Quality ind. Object 3</td>
<td>SI02</td>
<td>Enabled</td>
<td>Quality Indicator (GGA)</td>
<td></td>
</tr>
<tr>
<td>Numeric data display, right</td>
<td>Latitude Object 1</td>
<td>SI02</td>
<td>Enabled</td>
<td>Latitude (GLL)</td>
<td>Latitude (GGA) Latitude (GNS) Latitude (RMC)</td>
</tr>
<tr>
<td></td>
<td>Longitude Object 2</td>
<td>SI02</td>
<td>Enabled</td>
<td>Longitude (GLL)</td>
<td>Longitude (GGA) Longitude (GNS) Longitude (RMC)</td>
</tr>
<tr>
<td></td>
<td>COG Object 3</td>
<td>SI02</td>
<td>Enabled</td>
<td>COG true (VTG)</td>
<td>COG (RMC)</td>
</tr>
<tr>
<td>Doppler log indicator</td>
<td>n/a Longitudinal speed</td>
<td>SI03</td>
<td>Enabled</td>
<td>STW (VHW)</td>
<td>STW Longitudinal (VBW)</td>
</tr>
<tr>
<td></td>
<td>n/a Bow transverse speed</td>
<td>SI03</td>
<td>Disabled</td>
<td>STW transverse (VBW)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>n/a Stern transverse speed</td>
<td>SI03</td>
<td>Disabled</td>
<td>Stern transv STW (VBW)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>n/a Relative wind</td>
<td>SI05</td>
<td>Enabled</td>
<td>Wind direction rel (MWV)</td>
<td></td>
</tr>
<tr>
<td>Dual dial meter</td>
<td>SOG Dial Meter 1 Primary</td>
<td>SI02</td>
<td>Enabled</td>
<td>Speed (VTG)</td>
<td>Speed (RMC) SOG Longitudinal (VBW)</td>
</tr>
<tr>
<td></td>
<td>STW Dial Meter 2 Primary</td>
<td>SI03</td>
<td>Enabled</td>
<td>STW (VHW)</td>
<td>STW Longitudinal (VBW)</td>
</tr>
<tr>
<td>Horizontal ruler</td>
<td>R.O.T. Primary</td>
<td>SI04</td>
<td>Enabled</td>
<td>Rate of turn (ROT)</td>
<td></td>
</tr>
<tr>
<td>Compass dial</td>
<td>Heading Primary</td>
<td>SI04</td>
<td>Enabled</td>
<td>Heading true (HDT)</td>
<td></td>
</tr>
<tr>
<td>Anemometer Graph</td>
<td>Wind speed r Primary</td>
<td>SI05</td>
<td>Enabled</td>
<td>Wind speed rel knt (MWV) note 1</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Wind dir r Secondary</td>
<td>SI05</td>
<td>Enabled</td>
<td>Wind direction rel (MWV)</td>
<td></td>
</tr>
<tr>
<td>Echo sounder Graph</td>
<td>Depth Primary</td>
<td>SI06</td>
<td>Enabled</td>
<td>Depth (DPT)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Range Secondary</td>
<td>SI06</td>
<td>Disabled</td>
<td>Range (DPT)</td>
<td></td>
</tr>
</tbody>
</table>

Note 1) Decoders for other measuring units are available in the library.